Versabank clients – Mandatory Upgrade

Recently, you received a communication from Versabank about their upgrade to TLS 1.2.  This upgrade is required to provide you with the most up to date security features which aim to prevent fraud by providing secure communications.

As a result of the upgrade by Versabank, we will be making updates to Ascend with our August release to ensure our software continues to communicate with Versabank and you continue to have seamless banking functionality.

So with all of that being said, we are happy to inform you that in our upcoming August release, Ascend will be updated to communicate with Versabank via TLS 1.2 This will ensure secure end-to-end communication between Ascend and Versabank.

Please ensure that the August release of Ascend is installed on your system no later than September 14, 2018 to ensure continued functionality of your banking features.

With the topics of privacy and information security increasingly under scrutiny, Promeric continues to ensure your data stays secure.

Should you have any questions regarding this update, please do not hesitate to contact our support team at support@promeric.com.

Leave a Reply

Promeric Logo 2016
Welcome to our website!

If you are a new customer and would like to purchase one of our products, please click here to register an account.

If you are an existing customer, please click here to login.

For support please contact us at: 905.948.1777

Close

Ⓒ Promeric Technologies Inc